Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2025 - 02:00 CDT
Scheduled
We will be carrying out essential maintenance on 5/20/2025 between 02:00 to 04:00 Central US time.
During this time, we will be migrating Multi-Network SIM subscriber traffic from our Miami to Austin data center, ahead of the upcoming planned maintenance for the Las Vegas Data Center next week. Subscribers may disconnect and reconnect within the change window.
Services affected: Multi-Network SIM Subscribers may disconnect and reconnect within the change window.
Customer action required: No customer action is required.
Posted May 19, 2025 - 14:29 CDT
This scheduled maintenance affected: Connectivity - Solve Networks SIMs (Solve NA SIM Enhanced Network Infrastructure).